Fatal error: 'The original language does not exist: English'


ThemeBurn SupportForumsOpenCart ThemesPavilion OpenCart ThemeFatal error: 'The original language does not exist: English'

This topic has been marked as resolved.

So for my webshop I installed a dutch language pack. I deleted English as a language as I won’t be using that and thus I don’t have to fill in the English required forms for everything so it saves me time. However now I just tried to create an article with the Stories extension of BurnEngine and once I click add/create it gives me this error:

Fatal error: 'The original language does not exist: English' 
in /sites/mishop.nl/www/system/vendor/BurnEngine/extension/seo/admin/model/generatorModel.php:573
Stack trace:
#0 system/vendor/BurnEngine/library/DataBag.php(40): Seo_Admin_GeneratorModel->insertItemLanguageKeywords(Array, 'story', 6)
#1 admin/model/stories/index.php(20): TB_DataBag->__call('insertItemLangu...', Array)
#2 admin/model/stories/index.php(20): TB_ViewDataBag->insertItemLanguageKeywords(Array, 'story', 6)
#3 [internal function]: ModelStoriesIndex->insert(Array)
#4 system/storage/modification/system/engine/loader.php(169): call_user_func_array(Array, Array)
#5 [internal function]: Loader->{closure}(Array)
#6 system/engine/proxy.php(13): call_user_func(Object(Closure), Array)
#7 admin/controller/stories/index.php(94): Proxy->__call('insert', Array)
#8 admin/controller/stories/index.php(94): Proxy->insert(Array)
#9 [internal function]: ControllerStoriesIndex->edit()
#10 system/storage/modification/system/engine/action.php(44): call_user_func_array(Array, Array)
#11 admin/controller/startup/router.php(26): Action->execute(Object(Registry), Array)
#12 [internal function]: ControllerStartupRouter->index()
#13 system/storage/modification/system/engine/action.php(44): call_user_func_array(Array, Array)
#14 system/engine/front.php(34): Action->execute(Object(Registry))
#15 system/engine/front.php(29): Front->execute(Object(Action))
#16 system/framework.php(99): Front->dispatch(Object(Action), Object(Action))
#17 admin/index.php(22): require_once('/sites/mishop.n...')
#18 {main}

What would be the best workaround for me with this? I understand reinstalling the english pack would help but I’d rather not.

May 30, 2016 at 5:28 pm #48231


Have you removed English files as well? Generally, there is no problem to remove English in admin panel, but you will need language files.

If this is not your case, then we will need admin and ftp access, so we can explore the cause of this problem.

You can use hidepost to share private information with the support staff.

ThemeBurn team

May 31, 2016 at 6:21 pm #48256

Hello, I have the same problem when open and save existing category. I remove English language from admin panel, leave language files and get this error when try to save category. I don’t want use English language in admin panel because need put information for it when creating categories, products etc. We not use English.

  • This reply was modified 1059 days ago by  onejak.
June 29, 2016 at 9:41 pm #49188

I found where is problem.

After removing English language field SEO URL for it still persist in Categories and Products and it not be blank.

June 29, 2016 at 10:20 pm #49190

But how it fix it?

June 30, 2016 at 4:53 pm #49202

Now I see Notice in SEO Extension when English language removed from panel.

June 30, 2016 at 8:45 pm #49215


The problem is confirmed. We are currently working on a fix and will provide a patch ASAP.

ThemeBurn team

July 1, 2016 at 6:31 pm #49243


we attached a patched seo extension. Just extract the contents of the attached .zip file to the system/vendor/BurnEngine/extension folder. If the problem still persist you may want to reinstall (uninstall and then install) the seo extension.

ThemeBurn team

July 5, 2016 at 4:15 pm #49324

Yes, now all is fine! But what about Notices in log file and in SEO extension main page?

July 5, 2016 at 4:43 pm #49334

Did you reinstall the extension ?

July 5, 2016 at 5:04 pm #49343

No, I have upload patch only at that moment.

July 5, 2016 at 5:14 pm #49348

You have to re-install it, I guess.

July 5, 2016 at 5:26 pm #49352

Yes, after reinstalling it fixed. Thank you!

July 5, 2016 at 5:52 pm #49357

Happy to see everything is OK :)

ThemeBurn team

July 7, 2016 at 6:31 pm #49440

Fatal error: ‘The original language does not exist: English’

I have the same problem, Can you help me

February 5, 2018 at 6:31 am #63423
Viewing 15 posts - 1 through 15 (of 18 total)
  • You must be logged in to reply to this topic.