Mega Filter Pro not working with the latest BurnEngine version

ThemeBurn SupportForumsOpenCart ThemesBurnEngineMega Filter Pro not working with the latest BurnEngine version

This topic has been marked as not resolved.

Hi Team,

Last week we updated our theme to the latest version – Technopolis 1.1.2 and BurnEngine 1.2.2, because of the problem with the cart and checkout language not being changed as it should.

After the update, we noticed that Mega Filter Pro stopped working as it should – the filters are not available to select and the AJAX is not working. So we contacted the developers of the filter and their response was:

“The cause of problem is your new version of template which blocking AJAX requests so you should contact with the author of your template and ask them why the new version of template blocking AJAX requests.”

And so we are asking you. We hope that both issues can be resolved easily, because we are at the final steps of launching the website officially. :)

BR,
Stefan Pavlov

  • This reply was modified 243 days ago by  Kanisco.
  • This reply was modified 243 days ago by  Kanisco.
March 20, 2017 at 9:56 am #57575

Update:

When we switched off the Language url prefix and Default language url prefix from the SEO pack extension, the filters are active again. But when we apply some filter after the “ajax refresh” the results are not shown properly. They are set to 4 on a row and after the applied filter they are 15 (because thats the setting for product per page) at one row. You can check the attached screenshot. So we think that there is something really wrong with the SEO pack again :(

BR,
Stefan Pavlov

March 20, 2017 at 4:33 pm #57580

As stated here, can you please check if the latest version fixes these issues, because it contains some SEO pack fixes. If the fixes do not work, can you please check if the mega filter issues are only visual, i.e. do the product filter work as expected at least ?

Regards,
ThemeBurn team

March 23, 2017 at 8:33 am #57686

Hi Team,

We are sorry to inform you that the provided patch does not work. The ajax function is still not working when the language prefix is on. The only visible change after the patch is that when you turn off the prefix and filter the products, they are still not rendered 4 in a row, but also they are now invisible. As you can see on the screenshot.

BR,
Stefan Pavlov

March 23, 2017 at 10:03 am #57687

Okay,

we’ll check into your site.

March 23, 2017 at 10:15 am #57691

Hi Team,

Right after you commented our other thread, we entered the site and saw that even with ‘prefix on’ we could add products to the cart and the language stays the same. We have not done anything since we uploaded the patch and deleted all kind of cache in the morning 30 mins after you proposed of doing so, so we were really amazed that it was working and we could add products and the language stays correct.

Right after that we saw that you are doing something on the website. You turned off the prefix and started doing something with the filter because for some time it was working, and the products was not scrambled or invisible, after appliying some filters. So we decided not to answer right away, but to see what you will do. But now we saw that everything is the same as before, and nothings works correctly :( We created two videos for you, we think that is the best way to describe what our problems are.

Best Regards,
Stefan Pavlov

  • This reply was modified 239 days ago by  Kanisco.
March 23, 2017 at 9:36 pm #57707

We fixed the mega filter pro issues. Can you please check and confirm ?

March 24, 2017 at 4:23 pm #57724

Hi Team,

What can i say guys… you are magicians, Open Cart gurus! Everything works like charm. It is the best possible ending of the week for us! Cheers.

PS: Should we update when the new update is official or we are good for now?

Best Regards,

Stefan Pavlov

  • This reply was modified 238 days ago by  Kanisco.
March 24, 2017 at 4:40 pm #57727

You better do the upgrade once it is released, because we didn’t upload some frontend css fixes.

Regards,
ThemeBurn team

March 24, 2017 at 5:17 pm #57729
Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.