pavilion how can set “alt” tag to product image on product page?

ThemeBurn SupportForumsOpenCart ThemesPavilion OpenCart Themepavilion how can set “alt” tag to product image on product page?

This topic has been marked as resolved.

image of product on product page missing alt tag.
how to set alt tag same product name?

September 15, 2015 at 12:51 pm #43175

I am not a moderator but looked on my system and notice that the alt is added (taken) from the Opencart product name. (catalog/products/edit/ general / product ) Both the title=”product-name” alt=”product-name” use it. If you look at a page in a browser and type in Ctrl +F, then type in Alt if the search field they should show up.
Cheers,
Frank

September 15, 2015 at 2:12 pm #43177

Here is my url

@looserfoot please help me find alt on product on this page.

I can see alt of product image on this page like your demo site
http://shoppica.pavilion-theme.com/pink-casual-trousers

I can’t see alt of pink-casual-trousers’s image

I am i newbie please help me to set alt image on mysite.
Thank you.

  • This reply was modified 1158 days ago by  sugarsour01.
September 15, 2015 at 9:04 pm #43183

its there on the demo site..apparently Opencart or Pavilion adds it automatically.

Line 640:

“So in theory”, if you add a product name to your product in:
In Opencart (not Pavilion)
catalog – products… check your image – edit
The first item under the general tab is Product name. Fill that out and as best that i see, that will be the Alt associated with the image you add

Unless i’ve totally miss understood your question.
Cheers,
Frank

September 16, 2015 at 3:36 am #43188

For some reason it add the image not the code…but anyway…its line 640 … alt=”Pink casual trousers”
Hope it helps,
Frank

September 16, 2015 at 3:39 am #43189

Hi,

The image with the missing alt attribute is generated by a JS plugin. The original image has an alt tag.

BR,
ThemeBurn team

September 28, 2015 at 4:29 pm #43294

But why it is not showing on image tag created by zoom js plugin . Google crawling is not working fine as it is not crawling product page image .
Original image is 0*0 px there and google enable to crawl product detail page properly. Kindly suggest or suggest me the modification to do the same. I want js should add alt and title attribute into the image.

Thanks

November 1, 2018 at 10:46 am #65945

@artisanmetalshop

There is no reason Google won’t crawl your images, since they are in the code as markup. Image size is not of imported for the crawler.

As we’ve said in another topic, we cannot do anything here, since we use a third party plugin.

BR,
ThemeBurn team

November 8, 2018 at 2:28 pm #65993
Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.