"Region/State:" drop down not working

ThemeBurn SupportForumsOpenCart ThemesShoppica 2 OpenCart Theme"Region/State:" drop down not working

This topic has been marked as resolved.

My Theme: Shoppica2
My Opencart version: 1.5.3

The “Region / State:” drop down is blank and not displaying anything on the below places. Since it is a mandatory field, a user cannot proceed further.

1. While creating a new user.
2. While viewing the cart and trying to add a “shipping estimate”. The country option is visible and working properly, but region state is blank and nothing is there in the dropown either.

Thanks for this wonderful theme. Awaiting your earnest reply.

I saw a similar discussion post in opencart forum and it didn’t work for me as claimed. Just thought of sharing with you.

http://forum.opencart.com/viewtopic.php?f=20&t=42437&start=20

 nandak
May 28, 2012 at 8:03 am #9411

Hi,

Shoppica is not yet compatible with OpenCart 1.5.3.x.

We are working on the update and plan to publish the release in a couple of days.

Best,
ThemeBurn team

May 28, 2012 at 5:52 pm #9454

Thanks for the good news. Hope you guys do it in two days.
:-)

Since i am a coding novice, I installed opencart using softaculous within my cpanel. Softaculous installed 1.5.3 without my knowledge. Now, i am stuck with 1.5.3 opencart. I don’t know how to downgrade to 1.5.2 manually.

I will wait for your team to update shoppica2. All the best.

 nandak
May 28, 2012 at 5:58 pm #9457

I’m running opencart 1.5.3.1 along with the shoppica 2.0 theme and the state drop down does not work on the checkout page when i try and do a shipping estimate. I just installed yesterday and have loaded quite a few products, etc

May 29, 2012 at 11:10 pm #9516

as a sidenote i changed to the default theme and tested it and it works fine, so the issue only appears with the shoppica theme

May 29, 2012 at 11:48 pm #9520

I am having the same issue – having tried the above – switching back to the Default theme, the drop down has returned.

please can you advise to a solution?

with warm thanks,

Phil@Fastpartz

http://fastpartz.com

 Phil_L
May 30, 2012 at 7:37 pm #9549

has anyone come to a conclusion as how to solve/repair this issue?

with thanks,

P

 Phil_L
June 2, 2012 at 10:41 am #9660

I just deleted below line on shoppica2/account/register.tpl

if (typeof first_time === “undefined”) {
//$(“#register_form”).validate().element(‘#postcode’);
}
element method is not working at the moment but I do not know what is for that

than It is working.

but It is not a solution I guess,

I am just waiting for the best solution from shoppica2 Team.

Thanks,

  • This reply was modified 3301 days ago by  onlyjf.
 onlyjf
June 2, 2012 at 11:30 am #9662

I can’t launch my store until this issue is resolved and if I don’t launch soon, I won’t have a job any longer =( Any fixes for this yet ??

June 5, 2012 at 4:08 pm #9844

Quick Fix : open catalog/view/theme/shoppica2/template/account/register.tpl and replace register_form with register_details_form. You should replace it two times.

Shoppica 2.1.1. is coming and will fix all recent issues.

June 5, 2012 at 4:48 pm #9851

I found that on line 180, line 184, and on line 225. Do I change all three ?

June 5, 2012 at 11:38 pm #9868

This issue is already fixed in the latest Shoppica 2.1.1.

Best,
ThemeBurn team

June 11, 2012 at 10:19 am #10065

Sorry but I still get this error.

To reitterate: If I select a different country on the account/register page then the loading gif pops up but never goes away. I presume the ajax has died and so the state/region list never gets loaded.

Even happens to me using https://shoppica2.com/index.php?route=account/register

March 18, 2013 at 7:51 pm #20570

Hello Josh,

We should confess, that Shoppica 2 demo has not been updated for quite a long time. However, this does not mean that the problem is not fixed in the latest available release.

Best,
ThemeBurn team

March 19, 2013 at 1:42 pm #20646
Viewing 14 posts - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.