Issues with cart and checkout language

ThemeBurn SupportForumsOpenCart ThemesBurnEngineIssues with cart and checkout language

This topic has been marked as resolved.

Hi Team,

Yesterday we noticed a few issues with placing an order in our store, that occurred only from the English language version of the website:

1) When we click at the Add to cart button from the product page, the cart is reset back to the default language (picture 1).

2) The cart button shows “text_cart” instead of “Shopping cart” (picture 2).

3) At the checkout, the title of the steps for billing and shipping are in English language (that’s the chosen language), but the content and buttons are in the default language (picture 3).

So we decided to apply the latest update, because in the changelog we saw that the above mentioned issues are fixed – “[fixed] SEO pack – switching languages resets the cart menu to the default language”. But it’s not fixed at all. We are attaching screenshots. We are in the final steps of completing the store, but those issues will not allow us to launch it :( Hope to hear from you soon.

BR,
Stefan Pavlov

March 16, 2017 at 11:45 am #57460

And one more thing:

We have an option for most of our products, which is required by default and when you click on Add to cart without selecting the option, the error that is returned is in the default language as well. See the attached screenshot.

BR,

Stefan Pavlov

March 16, 2017 at 11:56 am #57469
March 16, 2017 at 1:42 pm #57480

Update:

Switching off the Language url prefix and Default language prefix in the SEO pack eliminates issue 1 and 3,but now the cart buttons show “text_cart” and “text_checkout”. We are not sure where and when exactly the buttons are shown like this “text_cart” and “text_checkout”. Sometimes, on some pages only one of the buttons is not shown correctly and the other one is correct. Still, this is not a solution for us and we hope that you provide a properly working fix.

BR,
Stefan Pavlov

March 20, 2017 at 4:58 pm #57582

Hi,

we attached a patch, which will update BurnEngine to the next version (due to be officially released in a few days). Can you please check and share if it fixes your issues ?

Regards,
ThemeBurn team

March 23, 2017 at 8:30 am #57684

Hi Team,

The provided patch is not working. The problem is still there. When you are on the second language and add something to the cart, it’s changed into the default language.

BR,
Stefan Pavlov

March 23, 2017 at 10:09 am #57689

Okay,

we’ll check into your site.

March 23, 2017 at 10:15 am #57690

Hi,

we cannot reproduce the ‘add to cart language issue’ with product options, as you can see on http://i.imgur.com/BJCdc4W.jpg

We change to ‘English’ language, enter a product and click ‘Add to Cart’. Do we miss something? Same goes for the ‘ Shopping Cart updated!’ message. It is displayed in the correct language for us.

Regards,
ThemeBurn team

March 23, 2017 at 5:47 pm #57698

Hi Team,

Right after you commented here, we entered the site and saw that even with ‘prefix on’ we could add products to the cart and the language stays the same. We have not done anything since we uploaded the patch and deleted all kind of cache in the morning 30 mins after you proposed of doing so, so we were really amazed that it was working and we could add products and the language stays correct.

Right after that we saw that you are doing something on the website. You turned off the prefix and started doing something with the filter because for some time it was working, and the products was not scrambled or invisible, after appliying some filters. So we decided not to answer right away, but to see what you will do. But now we saw that everything is the same as before, and nothings works correctly :( We created two videos for you, we think that is the best way to describe what our problems are.

Best Regards,
Stefan Pavlov

  • This reply was modified 239 days ago by  Kanisco.
March 23, 2017 at 9:35 pm #57706

Okay,

we identified the language issue and fixed it. Can you please check and confirm ? We’ll write about the mega filter pro in the corresponding thread.

Regards,
ThemeBurn team

March 24, 2017 at 3:25 pm #57717

Hi Team,

Yes, we confirm that the issue is fixed. But, the cart buttons are still shown like ‘text_cart’ and ‘text_checkout’ when you add a product to the cart. After you refresh the page, only one of them is shown like that. Screenshots attached. Can you confirm if it’s the same on your side?

BR,
Stefan Pavlov

March 24, 2017 at 3:41 pm #57718

We just found that ‘text_cart’ and ‘text_checkout’ labels are present in the default theme too. They are fine in the default Bulgarian language though, so we admit this is not a theme issue.

Regards,
ThemeBurn team

March 24, 2017 at 4:14 pm #57723

We’ve checked your language files and they do not seem to have all original language keys. Please download the OpenCart 2.3.0.2 package and make a comparison of the original catalog/language/en_gb/common/cart.php and those from your installation.

BR,
ThemeBurn team

March 24, 2017 at 4:23 pm #57725

Hi Team,

What can i say guys… you are magicians, Open Cart gurus! Everything works like charm. It is the best possible ending of the week for us! Cheers.

Best Regards,

Stefan Pavlov

March 24, 2017 at 4:39 pm #57726

Glad we’ve helped, Stefan and thanks for reporting these problems!

BR,
ThemeBurn team

March 29, 2017 at 9:23 am #57827
Viewing 15 posts - 1 through 15 (of 15 total)
  • You must be logged in to reply to this topic.