rule-based banner issue if theme cache on

ThemeBurn SupportForumsOpenCart ThemesPavilion OpenCart Themerule-based banner issue if theme cache on

This topic has been marked as not resolved.

hello support

i have an extension which called rule base banner

in my site, i have setup seven Rule-Based Banners in home page
monday to sunday, different weekdays different banner
but sometime, the banner doesnt show
for example, today 0:00 AM, the banner in the homepage should change to the thursday one, but it disappear
i need to go to my theme layout setting page to click “save” , after that the rule-based banner can show well.

i have tried to disable the cache setting in my theme, it seems that this kind of issue doesn’t appear again.

According to the reply of the developer of this extension

“If re-saving your theme layout seems to fix the issue, my guess is that it’s your theme caching that is causing this. That would be the only kind of caching that would affect this — my extension doesn’t have caching that would affect it like that, so it must be some outside caching. so you’d need to contact your theme developer about it, and ask them how to get the theme cache to clear at a certain time every day (perhaps by using a cron file). Or if their cache could clear itself every few hours, that may solve the issue as well.”

if i disable the cache, the extension run well, if i enable the cache , the Rule-Based Banners in home page disappear in everyday 0:00am, i need to go to the page builder in BE to click “save” button again so as to make the Rule-Based Banners appear again in home page.

i have disable the Content cache of this extension but it seems cannot resolve the problems, any advice?

thanks

  • This reply was modified 461 days ago by  Ken Yeung.
September 6, 2017 at 8:51 pm #61450

i am quite sure that it is caused by the cache problem, if the cache is on, the issue appear, it become normal and no problem if i turn off the cache.
i have turn off the Content cache of this extension in BE control panel. but it doesn’t help, i need to turn off the whole cache of theme to make it work well.

September 8, 2017 at 7:49 pm #61501
Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.