tb cache files are generating links pointing to another site

ThemeBurn SupportForumsOpenCart ThemesBurnEnginetb cache files are generating links pointing to another site

This topic has been marked as not resolved.

Hi, My site is burrmills.com and I have a problem where invalid links are generated inside cache files generated by Shoppica and these invalid links are pointing to another site which is not mine.

The files are in  ~/public_html/system/storage/cache/tb

cache.BurnEngine.category_flat_tree.XXXXXX

cache.BurnEngine.category_tree.XXXXXX

I have https throughout my site. I have taken steps to verify database is not compromised and made sure my public_html is not hacked, but still the issue persists. When I delete shoppica cache and browser cache the issue goes away and the site will work fine 2-3 days and then the cache will regenerate with the invalid links again.

I’ve contacted my hosting company (bluehost) and the third party SSL vendor and made sure SSL cert was issued and installed and working correctly

Please help! I bought my Shoppica them on 8/7/16 and I am still within the 6 month support period. I am using Opencart 2.2.0

The issue is there now. If you open my site burrmills.com and look at page source the links inside the div  tb_subcategories are pointing to a domain that is not mine (coppersinks.com). There is no references to this URL in my database or my public_html except the cache files mentioned above which are generated by Shoppica. If I remove the cache files in the server and the browser and re-load the page it will be fine, the cache will regenerate with the correct links, but the problem will re-appear after 2-3 days.

Here is some info from my Shoppica page

Info

Current store
Burr Mills (Default)
Current theme
Shoppica v3.0.1 /installed on 08.08.2016 19:07/
BurnEngine version
1.0.7 /installed on 08.08.2016 17:58/
OpenCart version
2.2.0.0
HTTP Server
Apache
MySQL server version
5.6.32-78.1-log
PHP version
5.4.43
PHP memory limit
256 MB
January 28, 2017 at 9:02 pm #55926

Please, uninstall the theme’s ‘OpenCart Performance+’ extension temporally. The next Shoppica version (should be released within a week) will contain a fix for this issue. You have to upgrade to it after it has been uploaded to themeforest (you’ll receive a notification).

Regards,
ThemeBurn team

January 31, 2017 at 8:15 am #55987

I do NOT have the theme’s ‘OpenCart Performance+’ extension installed. You mean to install it? Also, I downloaded version 3.1.5 from the website. Does this version has a fix for the problem or the next version?

  • This reply was modified 177 days ago by  mills21.
February 1, 2017 at 4:54 am #56015

No, do not install it. We just had similar problem when this theme extension is enabled, as some links were incorrectly generated to the admin panel. But none of these links were generated to another site.

Can you please provide a link to your real site where we can check these erroneous urls ?

Regards,
ThemeBurn team

February 1, 2017 at 9:06 am #56018

Hello, I would like to report exactly this same behavior with the last update of BurnEngine v3.2.4 – 7.04.2017

My menus, product pages, etc. are all linking to blog.iodragon.com
This is so annoying.

I have wasted a lot of time thinking I was hacked. The redirect stops when I clear the cache but it will come back the next day. Same as described above.

I have already uninstalled OpenCart Performance+

This issue is directly related with your cache plugin. As soon as I enable cache in the website this problem will come.

Please tell me what to do ?

April 20, 2017 at 9:24 am #58425

@kaliyas

Is the blog.iodragon.com domain yours?

April 20, 2017 at 11:15 am #58426

blog.iodragon.com is NOT mine.
I have never seen this domain before.

April 20, 2017 at 11:41 am #58428

I am experiencing the same problem from time to time. Sorry for hijacking the thread, but it might help in finding a solution.

1) My problem is, that the cache system sometimes saves other domains on the same server/host (in my case a combination of nginx as proxy and apache2 in the backend).

@kaliyas: Maybe you are on a shared hoster and somebody on the same server has the mentioned domain.

2) Another problem is, that language urls are saved wrongly. So for language A the urls for language B are saved.

Maybe it might make sense to tell, in which files exactly the urls are saved to file/cache. We could write a little hack and exclude unwanted domains from being saved.

 axanne
April 20, 2017 at 11:55 am #58429

Hi Axanne, no problem for jumping in. Thanks for your feedback.

I am hosting on cloudways with Digital Ocean, so it might be like the first case – combination of nginx as proxy and apache2.

It seems to happen only in the Chinese Language and working fine on English. I can’t test now. So I am not sure about this part.

April 20, 2017 at 12:50 pm #58430

@TB Support Private..

April 20, 2017 at 12:51 pm #58431

@kaliyas: So you are using a VPS. Rules out the shared hosting problem. Do you have other apps/domains/vHosts configurated in your Cloudways control panel? Do you have a default vHost?

If your server receives a request from an unkown/unconfigurated domain pointing to your server ip, nginx/apache redirect that request to the default vHost (if it doesn’t find the domain vHost). Which might be your main domain, if there are no other default vHosts configurated. And maybe during one of these requests, BurnEngine is saving those requests as a cache file and serving it to regular visitors, too.

Maybe somebody in the past used that server ip and his domain. And forgot to switch it off.

Obviously, it is just a guess, but could explain different domains being cached. And I believe, that was the problem with my 1st problem. Doesn’t solve the 2nd one, though. In any way, something doesn’t work right with the cache system on BurnEngine. An explanation, how it exactly works, could help us and many others to fix it.

 axanne
April 20, 2017 at 5:42 pm #58442
You will need to register in order to post topics and read replies in the ThemeBurn.com support forums!

Regards,
ThemeBurn team

April 21, 2017 at 11:00 am #58465

I ended up moving to a new server. Seems problems stopped.
Thanks for the support.

April 21, 2017 at 9:14 pm #58479

Hi,

Glad to see that you have resolved the problem!

BR,
ThemeBurn team

April 22, 2017 at 10:22 pm #58500
Viewing 14 posts - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.