No Products in Categorys

ThemeBurn SupportForumsOpenCart ThemesShoppica 2 OpenCart ThemeNo Products in Categorys

This topic has been marked as resolved.

Hello,

I have got a little problem with my Categories, they are empty.

Edit: Wrote this 8 Days ago… Now I add it to the Forum, maybe someone here could help

1 – Search:
• Without luck

2 – Update your theme/plugin
• Done

3 – 3rd Party Plugins:
I am using a Multistore, with a SEO plugin and Nitro Page cache. The SEO plugin is working fine with Shoppica 2, and I can see every Product. I have disabled Nitro Page cache for the shared .css and .js, and disabled it for the burnengine.tpl’s. Disabeling wont do the trick.

4 – Describing the problem:
I cannot see any products in categories. If I am locking @ webpagetest, there are no product images listed. When I enter an url of a product everything works fine. The shoppica skin/theme is mostly the same one as the default shoppica theme.

September 6, 2017 at 9:09 am #61414

Hi,

Which of the multi-stores are you referring to? We see the main store uses the default theme – should we change it to Shoppica?

BR,
ThemeBurn team

September 6, 2017 at 11:47 am #61422

Sorry, neraly all ecxept the Default one.

September 6, 2017 at 11:55 am #61426

Hi,

Your products show now. There were no blocks saved for your “All categories” scope for this store. We’ve added content, cleared both theme and nitro cache and everything seems fine now.

https://i.imgur.com/bmivgUq.png

BR,
ThemeBurn team

September 6, 2017 at 12:20 pm #61431

They are gone again…

Which .css, .js., .tpl etc. are loaded in the Categorys? Maybe I have to exclude some more roots, in the nitro extension.

For what are those xxxxx.css.tpl?

Another question:
Every time I upload Shoppica, it messes up with the resoulution in System/Settings/Images and overrides them for the Default Store. The Default Store allways had the same resolution vallues, as a freshed installed OC. Any suggestions?

September 6, 2017 at 1:00 pm #61435

I’ve Changed the login URL

September 8, 2017 at 11:32 am #61481

Any update yet?

September 12, 2017 at 1:41 pm #61542

Hi,

1) We see now you have commented subcategories in catalog/view/theme/BurnEngine/template/product/category.tpl. Unfortunately, you have commented a line more than you should and this breaks the listing layout.

Please restore the original category.tpl. If you need subcategories removed, this can be done easily from Page Builder > Content > All categories.

2) We automatically change image settings, but this should be only on theme installation.

BR,
ThemeBurn team

September 14, 2017 at 9:39 am #61599

Good Morning,

1) Sorry, but I definatly have not done such a thing. Never the less I have uploaded the category.tpl again. They have both the same size. 18.141bytes.

2) Good to know :)

3) I have a similar error in search, cannot see previews and if I hit enter no products are listet.

4) What are those css.tpl? Are those usual css, but not active unless you are using them in the Builder?

Ps.: Still not working

  • This reply was modified 34 days ago by  KnowHowTec.
September 14, 2017 at 10:05 am #61600

Another thing:
The categorys are trying to load images with the size 350×400. But it is set to:400×400.

September 14, 2017 at 10:26 am #61602

Regarding 1):

Since you said, it has something todo with category.tpl, I have made some changes in my test store (different root, domain and database):

1. Since it works on the default test store I have set up a Multistore (different domain, same root & database). There I have the same problem. The Images are loading and on mouse over the mouse changes to a finger, but are not visible.

2. I have deletet all Category related extensions on my test shop like:

Restrict Catalog By Customer Group
Price As Low As
Advanced Categories Modules

Without any luck

September 14, 2017 at 4:50 pm #61609

-> Solved
Another thing:
The categorys are trying to load images with the size 350×400. But it is set to:400×400.
-> Solved

September 14, 2017 at 5:08 pm #61611

Found it or at least a part of the problem :)

But I dont know how to solve it. :/

I have changed the Shoppica default productlisting to list, now I can see the images but it still quite messed up.

September 15, 2017 at 8:50 am #61621

Hi,

Changing default listing style will not help. Since you haven’t modded the category template then there should be some mod that does this. Duplicating the multi-store will reproduce the problem as the same modification is applied for each store. What you can do is to check which is the modification that is causing the problem, by disabling applied one by one.

CSS.tpl are PHP files that we use to create our CSS. We just insert lots of dynamic data inside.

P.S. Unfortunately we were not able to log into your FTP with the details you have provided.

BR,
ThemeBurn team

September 15, 2017 at 9:46 am #61622

Sorry, I have forgotten to ad a 0

Mybe I have used a non vQmod in the early days to disable “Symbol”-View, that would be the last thing I could think of, but I do not know wich file it would be.

  • This reply was modified 33 days ago by  KnowHowTec.
September 15, 2017 at 9:56 am #61624
Viewing 15 posts - 1 through 15 (of 20 total)
  • You must be logged in to reply to this topic.